Subject: RE: [Nomicmarket] Nomic Market beginning.

From: "Craig" <ragnarok@p...>
Date: Thu, 1 May 2003 22:18:06 -0400

>> >> OK, now that that's there (and while waiting for my message to show up
>> >> in
>> >> Thermo), I come to the market and convert all but one of my Coins into
>> >> 1000
>> >> BNS each. I'd better protect these puppies while I can.
>> >
>> >This post has been sent to both the market and B Nomic, as both an
>> >example of the hazards of free trade, and a request for any ideas of
>> >how B can fix its ruleset.
>> >
>> >The problem we have now is that if we legally recognize the Market,
>> >we're violating our Bank rule - it stipulates that there exist exactly
>> >5,000,000 BNS, but the Market stipulates that Craig's got 1000 more.
>> >How do we reconcile this?
>>
>> 2000, actually, and I've since gotten another 1000. However, I think that
>> protecting the stability of interaction is essential. Thus, if anyone
sees
>> this as dangerous, I will turn them back into three Coins.

>I think it needs to be rewritten to have the banks in B Nomic and thermo
>interact.

I hereby turn my 3000 BNS into 3 Coins and bring them into Thermo.

---

From: Doctor Ducker <drduck@u...>
Date: Fri, 02 May 2003 10:29:48 -0700

> I hereby turn my 3000 BNS into 3 Coins and bring them into Thermo.

First, these actions of your's haven't been legal within Thermo. Rule 0.5 hadn't yet been
passed when you started these things.

Second, at no point *could* you have removed your coins from Thermo into the Market, or returned
hence with coins. Even under Rule 0.5, the only Things that are allowed into the Market are
Players.

Third, and I think that this is the most fundamental of these details, There is no hazard *yet*
to B Nomic's Bank and BNS; There are effectively four "Object Types" in question: (1)
Thermo::Coins, (2) Market::Coins, (3) B-Nomic::BNS, (4) Market::BNS.

Craig's actions are as follows:
1) Entering the market, without *any* ruleset powers from Thermo.
2) Conjuring 2 Market::Coins out of thin air
3) Converting these Coins into 2,000 Market::BNS
4) Conjuring an additional Market:Coin out of thin air
5) Converting that Coin into 1,000 Market::BNS
6) Converting his 3,000 Market:BNS into 3 Market::Coins
7) Attempting to bring these Coins into Thermo, which is against Thermo's Ruleset because it
would be a change to the gamestate which is NOT defined within the ruleset.

Thus, the concerns are really rather moot as Craig never had any B-Nomic:BNS, with which to
effect the B-NomicBank. Also, Craig's actions, which were intended to safe-guard his Coins,
against a potentialls "dangerous" proposal within Thermo, were rather silly, because they had no
effect on his Thermo:Coins.

---

From: "Craig" <ragnarok@p...>
Date: Fri, 2 May 2003 16:27:41 -0400

>passed when you started these things.

Rule 0.5 would have explicitly granted me these powers. Instead, they were
implicitly granted by rule 4.4, as there are not any restrictions on
entering the market, even though there is no rule specifically saying that
there is one. I therefore CFJ on the following: There are currently no
restrictions in the rules on players entering the Nomic Market.

>Thermo::Coins, (2) Market::Coins, (3) B-Nomic::BNS, (4) Market::BNS.

I agree that there is no hazard *yet*. The potential hazard, however, is
enough for me to pull back out.

>1) Entering the market, without *any* ruleset powers from Thermo.

Rule 4.4

>2) Conjuring 2 Market::Coins out of thin air

They were the same two Coins that I had in Thermo.

>3) Converting these Coins into 2,000 Market::BNS

As the market rules explicitly empowered me to do.

>4) Conjuring an additional Market:Coin out of thin air

Which I had in Thermo.

>5) Converting that Coin into 1,000 Market::BNS

Again, the market ruleset lets me do this.

>6) Converting his 3,000 Market:BNS into 3 Market::Coins

And again.

>effect on his Thermo:Coins.

Yes, they did; the Thermo::Coins are the same objects as the Market::Coins,
the difference being in how they were being used. There was no net change,
however.

---

From: Doctor Ducker <drduck@u...>
Date: Fri, 02 May 2003 14:18:02 -0700

Craig wrote:

> there is one.

You're forgetting Thermo.Rule::6.5, which states "No changes to the gamestate may occur except
as defined in the ruleset". So what rule, specifically, prior to the passage of 0.5, allowed
you to arbitrarily destroy or remove Thermo::Coins from the gamestate of Thermo? And the same
question is actually still present after the passage of 0.5, since it only referrs to "players"
not eir possessions, and the concept of "entering the nomic market", does not in any way mean
that the gamestate of Thermo has changed, merely that the conditions within the Market.Rules for
entering the market are doable.

> I therefore CFJ on the following: There are currently no

Real life is getting in the way the last day or so, and I'm trying to catch up. I'll deal with
this explicitly within Thermo as soon as I can, but I'll pont out that with the passage of
Thermo.Rule::0.5, this *should* be trivially TRUE. Again, my point is that the issue is not
regarding "players" but rather Coins.

> enough for me to pull back out.

Acknowledged, especially as I don't know the ruleset of B Nomic, they may potentially have
issues that Thermo doesn't.

> >1) Entering the market, without *any* ruleset powers from Thermo.

Yes, you as a player. I'll even concede that the "thin air" in 2 and 4 is a COPY(made in
Market::Coins) of the Thermo::Coins your Thermo::Player self had, but in order to "remove" your
Thermo::Coins from Thermo, you would need a Thermo.Rule that allowed you to change the gamestate
in such a manner, there is no such rule.

> They were the same two Coins that I had in Thermo.

No, because the gamestate of Thermo was unchanged. At best they were copies.

> As the market rules explicitly empowered me to do.

Note I made no references as to any invalid actions here.

> >4) Conjuring an additional Market:Coin out of thin air

Nope, see above.

> Again, the market ruleset lets me do this.

Yup.

> >6) Converting his 3,000 Market:BNS into 3 Market::Coins

Yup. But upon returning to Thermo, even if you had skipped step 6, you would have found your
same 3 Thermo::Coins sitting in your possession, and no BNS.

> the difference being in how they were being used. There was no net change,

You have not yet stated how that can POSSIBLY be, as these are entirely different games. Any
object within one is NOT the same as another object in a different game, unless BOTH games
establish a set of transformations that allows such to occur. Thermo clearly does not have such
a set of Transformations, nor does Nomic Market, at least at this point.

---

From: "Craig" <ragnarok@p...>
Date: Fri, 2 May 2003 17:57:20 -0400

>> >> >> >> OK, now that that's there (and while waiting for my message to
show
>> up
>> >> >> >> in
>> >> >> >> Thermo), I come to the market and convert all but one of my
Coins
>> into
>> >> >> 2000, actually, and I've since gotten another 1000. However, I
think
>> that
>> >First, these actions of your's haven't been legal within Thermo. Rule
0.5
>> hadn't yet been

>entering the market are doable.

The gamestate is a rather vague concept.

>regarding "players" but rather Coins.

Ah, but 0.5 is not yet passed.

>issues that Thermo doesn't.

I do not know them either, but I understand that there is a perceived
potential threat.

>a set of Transformations, nor does Nomic Market, at least at this point.

The whole POINT of internomic trading is that they were the same objects.
Consequently, some further CFJs.

1. Craig successfully entered the Market prior to the submission of this
CFJ.
2. Craig successfully aquired three thousand BNS within the Market prior to
the submission of this CFJ.
3. For some period of time prior to the submission of this CFJ but after the
creation of the Nomic Market, Craig had zero Coins for the purposes of the
Market.
4. For some period of time prior to the submission of this CFJ but after the
creation of the Nomic Market, Craig had zero Coins for the purposes of
Thermo.
5. Craig currently has three Coins.

---

From: Doctor Ducker <drduck@u...>
Date: Fri, 02 May 2003 15:28:21 -0700

Craig wrote:

> > > > > > > > > in Thermo), I come to the market and convert all but one of my Coins into
> > > > > > > > > 1000 BNS each. I'd better protect these puppies while I can.
> > > > > > > >
> > > > > > > protecting the stability of interaction is essential. Thus, if anyone sees
> > > > > > I think it needs to be rewritten to have the banks in B Nomic and thermo interact.
> > > > >
> > > > First, these actions of your's haven't been legal within Thermo. Rule 0.5
> > > > hadn't yet been passed when you started these things.
> > >

That seems to be a distinct truism.

> Ah, but 0.5 is not yet passed.

Actually it has, I just haven't been able to update the ruleset just yet, though it should be in
about 10 more minutes.

> I do not know them either, but I understand that there is a perceived potential threat.
>
> The whole POINT of internomic trading is that they were the same objects. Consequently, some
> further CFJs.
>
> 1. Craig successfully entered the Market prior to the submission of this CFJ.
> 2. Craig successfully aquired three thousand BNS within the Market prior to the submission of
> this CFJ.
> 3. For some period of time prior to the submission of this CFJ but after the creation of the
> Nomic Market, Craig had zero Coins for the purposes of the Market.
> 4. For some period of time prior to the submission of this CFJ but after the creation of the
> Nomic Market, Craig had zero Coins for the purposes of Thermo.

Okay, first, in the spirit of fairness, I'll allow you te rescind that last one if you want.
Remember, that these sentences will be written into rules *as is* if they're found TRUE. Do you
really want a rule that says specifically and precisely how many Coins you have?

---

From: "Craig" <ragnarok@p...>
Date: Fri, 2 May 2003 18:57:01 -0400

>really want a rule that says specifically and precisely how many Coins you
have?

Whoops. No. Thank you for your forgiveness, o munificent stenographer.
Number five is withdrawn.

---

From: "Ian Kelly" <kellyia@e...>
Date: Fri, 2 May 2003 18:08:00 -0500 (EST)

Craig wrote:
>>Okay, first, in the spirit of fairness, I'll allow you te rescind that
>> last
> one if you want.
>>really want a rule that says specifically and precisely how many Coins
>> you
> have?
>

Actually, that could be useful for you to have. Spend a coin and you'll
still
have three.

Just hope you never need to spend more than three at a time...

Ian

---

From: "Craig" <ragnarok@p...>
Date: Fri, 2 May 2003 20:00:13 -0400

>Actually, that could be useful for you to have. Spend a coin and you'll

Yah, but I'm planning to be *much* richer than that in a bit...