Subject: Registration proposal of PsychicNathan

From: "psychicnathan" <nmccoy@o...>
Date: Wed, 14 May 2003 04:44:06 -0000

--- begin proposal ---

1. Create a Coin possesed by The Bank.

2. Destroy a Coin possessed by The Bank.

3. Restart from step 1 unless there are two more Therms than there are
players.

4. Create rule 5.901 in the group PROPOSALS: "Disregard rules 5.91,
5.92, and 5.93, unless rule 1.1 says 'No proposal may be passed if its
passage would directly increase the number of Things in the game,
unless it is explicitly permitted by rules in the group headed FIRST
SACRED LAW.'."

5. Create rule 5.91 in the group PROPOSALS: "Any player may Support a
pending proposal by stating the intent to Support that proposal and
giving any number of Coins to The Bank."

6. Create rule 5.92 in the group PROPOSALS: "When a proposal passes,
that proposal causes all Coins that were given to The Bank in
Support of that proposal to be destroyed."

7. Create rule 5.93 in the group PROPOSALS: "When a proposal fails,
return each Coin given to The Bank in Support of that proposal to its
previous owner, unless that player has been destroyed, in which case
assign that Coin to a random player."

8. If there are fewer than three Coins owned by The Bank, transfer
ownership of a random Coin not owned by The Bank to The Bank and
repeat step 8.

9. Destroy three Coins owned by The Bank.

10. Destroy this proposal.

---- end proposal ----

The purpose of this proposal is to avoid having to do weird stuff
(like steps 8 and 9 in this proposal) to balance the number of Things,
and instead allow players to contribute Coins to help balance a
proposal they like.
In case it wasn't obvious, once I'm registered I'm going to propose a
substitution of rule 1.1, so that proposals which change the number of
Things by an amount undetermined at the time of the submission can
still be submitted. I'd also suggest that rule 2.1 be changed to read
"If the enactment of a proposal decreases the number of Things by
three or more, a Coin is created in the ownership of the person who
submitted that proposal." I didn't want my registration to require a
unanimous vote, so neither of these were included in my registration
proposal.

---

From: "psychicnathan" <nmccoy@o...>
Date: Wed, 14 May 2003 15:04:01 -0000

> 3. Restart from step 1 unless there are two more Therms than there are

Oops. My first message and I'm already making potential endless loops.
Could someone make a Call For Judgement that this should be
interpreted as "...unless there are at least two more Therms..."? I
would, except I can't, and I really don't want to wait a week for this
proposal to stop pending before submitting another one with a slightly
different wording.

---

From: Doctor Ducker <drduck@u...>
Date: Wed, 14 May 2003 11:56:40 -0700

psychicnathan wrote:

> Oops. My first message and I'm already making potential endless loops. Could someone make a
> Call For Judgement that this should be
> interpreted as "...unless there are at least two more Therms..."? I would, except I can't, and
> I really don't want to wait a week for this
> proposal to stop pending before submitting another one with a slightly different wording.
>

Okay, I wouldn't have been voting at this point except that there are no provisions for
modifying a proposal once it has been submitted, and the CFJ process is simply too slow. If all
of the current players vote on this proposal it will become expired, and we won't have to wait a
full week for another reg. prop. from 'Nathan. I am hereby voting AGAINST this proposal.

I would, however, have preferred to have seen what you wanted to do to rule 1.1 before making my
vote.

As it currently stands I have a number of criticisms of this proposal:

1) steps 1-3, are a loop in the original form, and simply cause the creation of a single therm
in the modified form. This isn't even a case of get the destroys up to the level where you'll
get a coin (rule 2.1), since you are already destroying 4 other things. There are currently 7
Therms, and 4 players. Even if the calculation for step 3 included you, at the point when we
hit step 3 there would be 8 therms, and 5 players (4 + you).

2) Step 8 does nothing. The Bank currently possesses 1,000,000 Coins, so it has far *more* than
three Coins.

3) The rule 5.901 is completely frivolous without knowing what you intend for rule 1.1.

4) Rules 5.91 through 5.93 seem fairly interesting. In fact they seem to do exactly what we
want; Why do we need something else?

5) You end up creating 4 rules, and destroying 3 coins, and the proposal, plus whatever from
steps 1-3. That means you aren't even making use of the fact that you've got a registration
proposal, which would allow you to create one extra thing (rule 1.2)

6) Why is your suggested change to 2.1 any better than how it already is? Currently the rule
reads: "Any player who submits a proposal that would destroy at least three Things recieves a
Coin if that proposal passes."

7) Unanimous? No, that's not how it works. A non-TSL modifying proposal needs more For votes
than Against votes, a TSL modifying proposal needs more For votes than *Abstain* votes, with
Against votes acting as vetoes.

Let me show you what *might* have done the sort of thing you're talking about:

<begin -not-a-registration-proposal-from-PsychicNathan->
If 2 or more Coins have been donated to the cause of this proposal, by eir possessors having
stated such an intent and transfered said Coins to The Bank, then only perform items 1 through
6, otherwise only perform items 7 through 8.

1. Destroy the Coins which were donated to the cause of this proposal.

2. Create rule 5.91 in the group PROPOSALS: "Any player may Support a pending proposal by
stating the intent to Support that proposal and giving any number of Coins to The Bank."

3. Create rule 5.92 in the group PROPOSALS: "When a proposal passes, that proposal causes all
Coins that were given to The Bank in Support of that proposal to be destroyed."

4. Create rule 5.93 in the group PROPOSALS: "When a proposal fails, return each Coin given to
The Bank in Support of that proposal to its previous owner, unless that player has been
destroyed, in which case assign that Coin to a random player."

5. Randomly determine a player, and create a Coin in said player's possession. (a little
bribery never hurts)

6. Destroy this Proposal.

(4 Things created, 1 specifically destroyed, and at least 2 Coins destroyed -> Means up by at
most the allowed registration proposal amount)
----------

7. If any Coins have been donated to the cause of this proposal, then transfer said Coins out of
The Bank, and to eir previous possessors.

8. Create a Coin in the possession of PsychicNathan.
<end -not-a-registration-proposal-from-PsychicNathan->

---

From: "Craig" <ragnarok@p...>
Date: Wed, 14 May 2003 16:41:26 -0400

>full week for another reg. prop. from 'Nathan. I am hereby voting AGAINST
this proposal.

And I FOR. I figure assuming that it implies the desired interpretation is
legit, since we aren't using precise mathematical language in this game.

>I would, however, have preferred to have seen what you wanted to do to rule
1.1 before making my

As would I, but I can always vote down a change I don't like.

>hit step 3 there would be 8 therms, and 5 players (4 + you).

The goal is to give everyone Coins, I think.

>3) The rule 5.901 is completely frivolous without knowing what you intend
for rule 1.1.

Even so, it is frivolous. Whatever proposal changes 1.1 could always remove
those two rules.

>want; Why do we need something else?

Then why did you vote against?

>proposal, which would allow you to create one extra thing (rule 1.2)

Oh well. E doesn't have to, and e is already creating extra things with
steps 1-3.

>Coin if that proposal passes."

I agree, but I don't see that as a problem with a proposal that doesn't deal
with that.

---

From: Doctor Ducker <drduck@u...>
Date: Wed, 14 May 2003 15:44:44 -0700

> legit, since we aren't using precise mathematical language in this game.

Acknowledged, I will use the fuzziness of language to get us "out" of the loop, if this passes.
However, I will also state my distaste for encouraging ambiguity like this.

> As would I, but I can always vote down a change I don't like.

Granted, but it still would have been polite ;)

> The goal is to give everyone Coins, I think.

The intention may have been, but the actual actions do nothing of the sort. In psuedo-code:
Do {
Create Coin
Destroy Coin (+1 Therm)
} Until (Therms = (players +2) )

in the modified form the Until is: (Therms >= (players+2) )

The problem is that players=4 -or- 5 (including Psy'Nathan), and Therms=7, before this starts,
which already satisfies the conditions, therefore the original form is as I've already said a
loop, and the second only increases the number of Therms by one.

As far as activating rule 1.3, the proposal destroys enough things already. With (1-3) Before:
7 Therms, 4 Players; After: 12 Therms, 5 players. Without (1-3) Before: 7 Therms, 4 Players;
After: 11 Therms, 5 players. Thus Therms-players=7 -or- 6, either of which does the job.

> Even so, it is frivolous. Whatever proposal changes 1.1 could always remove those two rules.
>

Because of the overall complexity of the proposal. It makes me jump through hoops unnecessarily
(see my suggested re-write), to get everything done, and it strikes me that Psy'Nathan hasn't
really read through the rules as thoroughly as _I_ would prefer. The rule set isn't overly
huge, so that barrier is still pretty low.

> Oh well. E doesn't have to, and e is already creating extra things with steps 1-3.
>

But e's not creating anything, just increasing the Therms by 1, with (1-3), that was my point
above.

> I agree, but I don't see that as a problem with a proposal that doesn't deal with that.
>

True, and this wasn't actually part of why I voted Against, just part of the criticisms in
general.

---

From: "Craig" <ragnarok@p...>
Date: Wed, 14 May 2003 19:41:16 -0400

>> > of the current players vote on this proposal it will become expired,
and we won't have to
>> wait a

>However, I will also state my distaste for encouraging ambiguity like this.

I agree, but think that it's too late to deal with this case. Just don't do
it in the future, PsychicNathan or anyone else.

>> > I would, however, have preferred to have seen what you wanted to do to
rule 1.1 before
>> making my

>Granted, but it still would have been polite ;)

Maybe the rest of us are supposed to be psychic too.

>> > 1) steps 1-3, are a loop in the original form, and simply cause the
creation of a single
>> therm
>> > in the modified form. This isn't even a case of get the destroys up to
the level where
>> you'll
>> > get a coin (rule 2.1), since you are already destroying 4 other things.
There are currently
>> 7
>> > Therms, and 4 players. Even if the calculation for step 3 included
you, at the point when
>> we

>The intention may have been, but the actual actions do nothing of the sort.
In psuedo-code:

Yes, they do. They create enough Therms that when the other actions of the
proposal are done, we are left with enough Therms to give everyone a Coin.

>loop, and the second only increases the number of Therms by one.

E should have looked up how many there were, or divined the answer by
supernatural art, or whatever. But no harm is done.

>huge, so that barrier is still pretty low.

Yeah, I agree. E's new to the game, but as e gets going I certainly expect
to see some improvement.

steps 1-3.

>But e's not creating anything, just increasing the Therms by 1, with (1-3),
that was my point

E is creating a Coin for each player by combining steps 1-3 with a couple of
other deletions.

---

From: "psychicnathan" <nmccoy@o...>
Date: Thu, 15 May 2003 02:45:32 -0000

> 1) steps 1-3, are a loop in the original form, and simply cause the
creation of a single therm
> Therms, and 4 players. Even if the calculation for step 3 included
you, at the point when we
> hit step 3 there would be 8 therms, and 5 players (4 + you).

This brings up another point I'd like clarification on, specifically
on how exactly the resolution of proposals works. Does a player join
the game before or after the execution of eir registration proposal?
Also, do rules take effect as soon as they are added to the ruleset or
after the proposal that added them finishes being applied? If a
proposal destroys itself before it would do something else, does the
something else still happen?

> 2) Step 8 does nothing. The Bank currently possesses 1,000,000
Coins, so it has far *more* than

I was having trouble figuring out how many Coins the Bank had, and I
wanted to make sure that the bank _would_ have three Coins no matter
what, so my proposal wouldn't fail automatically if it didn't have
three in it already. I was finding it difficult to determine the state
of the game in general, so I also wanted to make sure the number of
Therms would be enough to give everyone a Coin. Also, how did the bank
get so many Coins without violating the rules? Did it have to do with
the fact that rule 1.1 says "...directly increase the number of
Things...", and a proposal indirectly increased it somehow? Aren't
there now a million free Things we can create by destroying Coins in
the bank to balance it out? Perhaps there should be a rule 5.94 that
says "A proposal may not move or destroy Coins in the Bank unless
those Coins were given to the Bank in Support of that proposal"?

> 3) The rule 5.901 is completely frivolous without knowing what you
intend for rule 1.1.

My intent for rule 1.1 was to change it to 'No proposal may be
_passed_ (it currently says submitted) if its passage would directly
increase the number of Things in the game, unless it is explicitly
permitted by rules in the group headed FIRST
SACRED LAW.'
This seems significant to me because it is unclear how the rules
handle a proposal that changes the number of Things by an undefined
amount. It would allow proposals that could possibly violate the First
Sacred Law to be submitted, but not let them be passed unless they
wouldn't. This goes with the Coin/Support thing. I set up 5.901 to
avoid activating the rules until they would work with that, although I
see now that it was unnecessary.

> proposal, which would allow you to create one extra thing (rule 1.2)

I didn't realize that the submission of the proposal doesn't count for
the purposes of 1.1, but the destruction of it does (so it is possible
to gradually increase the number of Things by submitting proposals
that create one thing and destroy themselves.)

> Coin if that proposal passes."

Because I understood this to be a reward for "cleaning up", but with
the current wording anyone can get the free Coin simply by creating
three things and then destroying them. Combine this with the "destroy
this proposal" balance, and you get get two more Things in the total
with each proposal. My wording fixes this to work as it seemed to be
intended to work. (the Comment on the First Sacred Law says "The
number of things can only increase when the game is influenced by
external people.", but this is not the case currently.)

> most the allowed registration proposal amount)

This does in fact match up with my intent, and is a much more elegant
wording than what I proposed. If my current registration proposal
fails, my next one will probably be:

<begin potential-registration-proposal>
1. Create 100 coins that belong to The Bank.
2. Destroy 103 coins that belong to The Bank.
3. Create rule 5.91 in the group PROPOSALS: "Any player may Support a
pending proposal by stating the intent to Support that proposal and
giving any number of Coins to The Bank."
4. Create rule 5.92 in the group PROPOSALS: "When a proposal passes,
that proposal causes all Coins that were given to The Bank in Support
of that proposal to be destroyed."
5. Create rule 5.93 in the group PROPOSALS: "When a proposal fails,
return each Coin given to The Bank in Support of that proposal to its
previous owner, unless that player has been destroyed, in which case
assign that Coin to a random player."
6. Create rule 5.94 in the group PROPOSALS: "A proposal may not move
or destroy Coins belonging to The Bank unless those Coins were given
to The Bank in Support of that proposal."
7. Create rule 5.991 in the group PROPOSALS: "The person who submitted
a proposal that is pending may destroy that proposal by announcing eir
intent to do so on the mailing list."
8. Destroy this proposal.
<end potential-registration-proposal>

Does anyone foresee any problems that the above proposal might cause?

Incidentally, this is the first time I've played any kind of Nomic,
although I do play Magic: the Gathering, which is similar in that it
is played within a framework of rules that can essentially be altered
by applying those rules (specifically, by playing cards that change
the way the game is played).

---

From: Doctor Ducker <drduck@u...>
Date: Thu, 15 May 2003 01:56:57 -0700

> something else still happen?

Essentially, as Speaker, I've been performing these actions to the best of my understanding.
I've been operating on the principle that everything within a proposal's passage happens as a
unit with regard to the rest of the game, but inside the proposal in the order it appears or
dictates. With regard to player registration, I've been counting the actual registration as
being a _part_ of the proposal, and checking rule 1.3 after the proposal is done. While doing
things this way might not be strictly adhering to the letter of the rules, it does seem to me to

be the spirit of them.

> three in it already.

Ah, my apologies. I've been keeping the info on a geocities site,
http://www.geocities.com/ducker756/thermo.html

> I was finding it difficult to determine the state
> Things...", and a proposal indirectly increased it somehow?

There was at one point a rule which read: "When a proposal is passed, this rule is destroyed and

1,000,000 Coins are created in the possession of the Bank."
When the next proposal to pass did so the rule created the coins, and then went away... It's
not _quite_ as hard as it seems to get new Things. Also if you look back through the messages
to the stuff around the beginning of April, you'll find a message (#64) where I list some less
than obvious ways to get new Things into the game.

> Aren't there now a million free Things we can create by destroying Coins in

Look back to some of the more recent messages (starting with #532), for some of the ideas we've
been beating about.

> permitted by rules in the group headed FIRST SACRED LAW.'

hmmm, I'm very leery of alteration to the TSLs, and I'm really not sure this is needed.
Remember these are _Sacred_ after all... ;)

> amount.

The way we've been operating is to follow the instructions of a proposal. This would mean that
conditionals could be used, and is exactly what I do in my suggested re-write of your proposal.

> It would allow proposals that could possibly violate the First

> that create one thing and destroy themselves.)

Yup, that's exactly one of the points I make in message (#64)

> three things and then destroying them.

Ah, no, my interpretation of the intent of 2.1 is to _encourage_ entropy through the increase in

Therms, nothing to do with cleaning up...

> Combine this with the "destroy this proposal" balance, and you get get two more Things in the
total
> with each proposal.

Actually you don't, since you only get the Coin _if_ the proposal passes...

> My wording fixes this to work as it seemed to be

Well, it's correct that as things currently stand there are actually many ways to get more
things, but that "Comment" doesn't have the force of law (rule 4.3), so it could just as easily
read "we do the hokey-pokey" ;)

> > 6, otherwise only pe. . .

<SNIP>

> > . . . ted to the cause of this proposal, then transfer said Coins out of

> wording than what I proposed.

I'm flattered. But that was simply to give you an idea of a way you could work things.

> If my current registration proposal fails, my next one will probably be:
>

You don't need to create and destroy the hundred extra Coins. You'll already be destroying 4
things, and
thus bringing the therms up to 11, and that'll take the Therm level over the 10 needed
(guaranteed) to activate rule 1.3 .

Also, look over the ideas we've had regarding possession (message 532+) before including 5.94,
or 5.991

Actually look over this language:

<begin not-a-proposal>
Destroy 2 Coins in the possession of The Bank.

Create the following three rules:

o 5.91 A Proposal may request a Support of Coins be established for said proposal, and if
destroying said Coins as an action of said proposal would allow said proposal to become pending,

then the destruction of all Coins assigned to said proposal's Support of Coins is considered an
action of said proposal, and thus said proposal becomes pending.

o 5.92 Any player may assign any number of Coins which said player possesses to be considered
part of a proposal's Support of Coins.

o 5.93 Any Proposal which has not become pending within one week of it's submission is
destroyed.

Randomly determine a player to recieve possession of a newly created Coin.

Destroy this proposal
<end not-a-proposal>

Therms go from 7 to 10
Players will be at 5

thus 5 more therms than players, everybody gets a Coin... ;)

Yeah, 5.91 is kinda convoluted, but it's hard to get it all into a single sentence. But what it

all means, is that a proposal may recruit support, by requesting a "Support of Coins", with
which it can use to create new things. A TSL violator could thus become a non-TSL violator, and

thus a pending proposal. It also means that a proposal has a limited time in which to gain such

support (5.93). Support is however restricted to only the Coins in possession of Players
(5.92).

> the way the game is played).

You're not doing too bad, I'd simply suggest reading the rules a bit more critically, as well as

looking over the archives of the mailing list to avoid wasting effort on things which have
already been discussed and figured out, not too mention as a source of ideas.

Also, how did you come upon Thermo?

And again, I keep the records, as both Speaker and Stenographer, at
http://www.geocities.com/ducker756/thermo.html

---

From: "Craig" <ragnarok@p...>
Date: Thu, 15 May 2003 16:44:05 -0400

>Look back to some of the more recent messages (starting with #532), for
some of the ideas we've

Basically, the hope was to establish an economy. I am leery of most other
uses for the Coins.

>Therms, nothing to do with cleaning up...

Yup. As the writer of the initial rules, I will state that the idea was to
encourage people to drop the number of things in the game.

>read "we do the hokey-pokey" ;)

The intent was much stronger than what actually happened. The comment tells
what was intended rather than what we've found it actually means. But Dr
Ducker is right about the hokey-pokey, in fact one recent proposal contains
a line "Let's do the happy-dance." Meaning, perhaps, that Thermo is in a
state of happy-dancing right now. Or perhaps not.

---

From: "Craig" <ragnarok@p...>
Date: Mon, 19 May 2003 15:51:52 -0400

Just wanted to point out that so far I think only Dr Ducker and I have
voted. Josh, unlin_e, please vote on the registration proposal of
PsychicNathan.

---

From: cortex <cortex@n...>
Date: Mon, 19 May 2003 17:55:56 -0400

> voted. Josh, unlin_e, please vote on the registration proposal of

Oop. This'd be a resolute ABSTAIN, then.

Josh
-- 
This is my signature. * BEHOLD! * (1) cortex@n...
There are many like it, * Josh Millard * (2) /~cortex at same
But this one is mine. * OBEY! * (3) the voice in yer head

---

From: sonof <unlin_e@y...>
Date: Tue, 20 May 2003 13:14:53 -0700 (PDT)

> Oop. This'd be a resolute ABSTAIN, then.

unlin_e is AGAINST.

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com