Subject: MN: MCMapper

From: "Snow" <snowl@s...>
Date: Sun, 7 Nov 1999 15:27:51 -0000

I've finally got this thing working. MCMapper is a program to get Station Currents from a JPEG or
GIF image.

www.snow.vg/program/mcmapper.html

The interface is rather primative, as is the programming, the design is almost non-existant, it's
riddled with bugs and could do with a good deal more functionality, but it will get the Station
Currents out if you try hard enough.

You will need a Java 1.1 VM to run it. I've tried it on MS JView v5 and Sun JRE v1.1.6 which worked
fine and Sun JDK v1.2 which didn't.

I have converted Dunx's map data so that it can be read by MCMapper (hope you don't mind Dunx), but
the data structures are slightly different, so it's not optimal.

Could anyone recommend a book on OO software design, preferably aimed at the kind of person that
finds For Dummies books challenging?

Snow
-Converting the Ruleset to XML.

---

From: "Ole Andersen" <palnatoke@g...>
Date: Sun, 7 Nov 1999 21:33:04 +0100

Snow wrote:

:
: You will need a Java 1.1 VM to run it. I've tried it on MS JView v5 and
Sun JRE v1.1.6 which worked
: fine and Sun JDK v1.2 which didn't.

I get these Javathings at my usual Java retailer?

:
: I have converted Dunx's map data so that it can be read by MCMapper (hope
you don't mind Dunx), but
: the data structures are slightly different, so it's not optimal.

Ahh.. how are your structures?

:
: Could anyone recommend a book on OO software design, preferably aimed at
the kind of person that
: finds For Dummies books challenging?

My fave book on this subject is in Danish, and it isn't very good, so... No.

:
: Snow
: -Converting the Ruleset to XML.
:

Wow!

Ole

---

From: "Snow" <snowl@s...>
Date: Mon, 8 Nov 1999 22:20:42 -0000

> I get these Javathings at my usual Java retailer?

Since you're running IE5 you probably have MS JView already. To check type jview at a command
prompt, if it does anything other than "Bad command or file name" then you have a Java VM and it's
almost certainly v1.1 compatable.

Snow
-Experiencing the kind of pleasure that can only be achieved by listening to a 12min drum solo.