Subject: Proposal: "Nomic Dock Topology"

From: "Steppen Ling" <[email-masked]>
Date: Fri, 7 Sep 2001 13:05:23 +0200

Enact a new rule, "Nomic Dock Topology", with the following text:
"
The Map is the only legal representation of the Nomic Dock and is part of
the Gamestate.
The Map is a square of 4x4 tiles, where each tile is a Warehouse assigned
for reference with an unique integer number between 1 and 16.
The Waters reach 3 sides of the square, while the fourth connects to the
Inland, as in Picture 1. [[attached]]
"

Also, append to rule 1001 ("Companies") the following text:
"
[paragraph break]
The position of the Companies' Warehouses on the Nomic Dock is part of the
Gamestate.
If at any time the position of a Company's Warehouse is unknown, it will be
set to a random unassigned Warehouse on the Nomic Dock.
"

~Steppen~

----------

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~ *************************** ~~~~
~~~~~* +---+ +---+ +---+ +---+ * ~~~~
~~~~ * | 1 | | 2 | | 3 | | 4 | * ~~~~
~~~~ * +---+ +---+ +---+ +---+ * ~~~~
~~~~~* +---+ +---+ +---+ +---+ * ~~~~
~~~~ * | 5 | | 6 | | 7 | | 8 | * ~~~~
~~~~ * +---+ +---+ +---+ +---+ * ~~~~
~~~~~* +---+ +---+ +---+ +---+ * ~~~~
~~~~ * | 9 | |10 | |11 | |12 | * ~~~~
~~~~ * +---+ +---+ +---+ +---+ * ~~~~
~~~~~* +---+ +---+ +---+ +---+ * ~~~~
~~~~ * |13 | |14 | |15 | |16 | * ~~~~
~~~~ * +---+ +---+ +---+ +---+ * ~~~~
*************************************
*************************************
************ I N L A N D ************
*************************************

Picture 1. Legend: ~ = Waters; * = dry land.

[Non-text portions of this message have been removed]

---

From: [email-masked]
Date: 10 Sep 2001 12:52:13 -0400

> set to a random unassigned Warehouse on the Nomic Dock.

ACCEPTED. +11 Plinks.

-- 
- Doc

---

From: [email-masked]
Date: 10 Sep 2001 13:58:10 -0400

I've made a representation of the dock layout in the rules using
tables... hope it comes out OK in various browsers...

> set to a random unassigned Warehouse on the Nomic Dock.

$ rand.pl -n 6 -u 1 16
6 unique random ints 1 <= x <= 16:
12
5
2
7
9
13

Assigning these to companies in the order shown on the GNDT, we have

2 FirstVirtualShipping
5 fnordCo
7 FlyingPenguinsLtd.
9 UnlimitedShippingLtd.
12 TurboCorp
13 IdealWareLtd.

These are shown on gamedata page.

-- 
- Doc

---

From: "Steppen Ling" <[email-masked]>
Date: Wed, 12 Sep 2001 22:12:08 +0200

> tables... hope it comes out OK in various browsers...

It's perfect. The layout in the partial game state page is good, too, but
perhaps you should remove the "unassigned" tag from the unassigned tiles; so
it will be easier to find where are the assigned ones at a moment's glance.

Steppen

---

From: "Steppen Ling" <[email-masked]>
Date: Thu, 13 Sep 2001 13:29:38 +0200

> ACCEPTED. +11 Plinks.

Abiding to NSFRule 1007, as Economist For A Day I wish to raise the price of
both Flour and Plastic Spoons (thus making the prices become, roughly, both
6 Plinks).

Steppen

---

From: [email-masked]
Date: 13 Sep 2001 10:32:07 -0400

> both Flour and Plastic Spoons (thus making the prices become, roughly, both

OK, game state updated.

-- 
- Doc