Subject: Pharmacist and Hospital Building Engineer Office Hours Postponed

From: "Jeffrey J. Weston" <[email-masked]>
Date: Thu, 15 Feb 2001 09:30:17 -0800 (PST)

Seems I have more pressing matters that require my attention at
the toilets.

---

From: [email-masked]
Date: 15 Feb 2001 12:15:12 -0500

> Seems I have more pressing matters that require my attention at

Well, shit...

-- 
- Doc